MacOS X Install

From Geoqo
Revision as of 01:54, 12 January 2007 by Yamar (Talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Here's a conversation between vaccine and Yamar about getting it working on Mac OS X:

 vaccine: For OS X:
 
 vaccine: You will need expat if you don't have it already - http://sourceforge.net/projects/expat/
 
 vaccine: run ./check-prerequisites.pl  and install missing pieces
 
 vaccine: You will need HTML::Tagset for the optional WWW::Babelfish module
 
 vaccine: I needed to install expat first
 
 Yamar: expat from source?  nopre-package?
 
 vaccine: umm
 
 Yamar: (ie, not on the install OS X CD)?
 
 vaccine: yeah.. I just d/l'ed 2.0 off the sf page
 
 vaccine: yep.. got the source and just compiled it
 
 vaccine: and install missingpieces was all done with CPAN
 
 vaccine: oh..
 
 vaccine: and your cpan command will require OS X users to use "sudo"
 
 Yamar: not surprising.
 
 Yamar: (as it should be)
 
 vaccine: on your "getting.html" page
 
 vaccine: this: Run perl -MCPAN -e shell and at the prompt type "install MODULENAME" for each listed module you need or want
 
 vaccine: for OS X will be Run sudo perl-MCPAN -e shell
 
 vaccine: outside of that, it was all the same =)
 
 Yamar: ah, true.
 
 Yamar: I should have at least put "as root"
 
 vaccine: oh, and this all assumes that the OS X user has the dev tools
 
 vaccine: by default there is no compiler on OS X
 
 vaccine: you need to install the developer tools (which is free) 
 
 vaccine: it's just seperate
 
 vaccine: it's either on theOS media..
 
 vaccine: or available at Apple's site
 
 vaccine: http://developer.apple.com/tools/
 
 vaccine: http://developer.apple.com/tools/download/
 
 vaccine: that's the download
Personal tools